visual-studio-2010 - 无法安装Silverlight Developer运行时

我已经在Windows 7中完整安装了VS 2010 Professional。

我已经单独安装了Silverlight 5.0。

当我创建silverlight应用程序时,它会要求安装silverlight Developer运行时。

You need to install the latest Silverlight Developer runtime before creating a Silverlight project



在下载运行时后,当我尝试安装它时提示

newer version of Silverlight is already installed



因此,我无法安装运行时,也无法创建siverlight应用程序。

我尝试安装Silverlight 5工具,但它要求安装Visual Studio Service Pack 1。
系统中已经安装了Microsoft Silverlight 3 SDK和Microsoft Silverlight 4 SDK。为什么SDK不包括开发人员运行时?

开发Silverlight应用程序需要什么?

最佳答案

Silverlight 5需要Service Pack 1。

我建议(根据我最近的经验)

  • 卸载拥有
  • 的所有“Microsoft Silverlight”
  • 确保已安装SP1
  • 从此处安装Silverlight 5工具:http://www.silverlight.net/